Prusa Knowledge Base

Minimum system requirements

Relevant for:
Last updated 13 days ago
This article is also available in following languages: 

Hardware configuration

CPU: Many computations in PrusaSlicer are multi-threaded and will benefit from a processor with multiple cores and threads.

Memory: Minimum 4 GB RAM, recommended is 8 GB or more.

Graphics: Needs to support OpenGL version 2.0 and newer.

Operating systems

Windows - 64-bit Windows 7 and newer. PrusaSlicer 2.4.2 is the last version with a 32-bit Windows build available.

OSX - 10.11 (El Capitan) and newer versions. OSX 10.12 (Sierra) and newer will be required for versions after 2.4.2.

Linux - most standard Linux distributions.

Chromebook - current version of Chrome OS with Debian 10.7 or newer.

Follow this link for information about PrusaSlicer installation.

Comments

Please sign in before adding a comment.
0
Still have questions?

Still have questions?

If you have a question about something that isn't covered here, check out our additional resources.
And if that doesn't do the trick, you can send an inquiry to info@prusa3d.com or through the button below.